zentaoPHP框架系统要求

2009-04-04 21:38:58
王春生
25304
最后编辑:王春生 于 2016-08-19 08:18:23
简介:本篇文章介绍zentaoPHP框架的环境要求。

zentaoPHP框架是基于php5版本的oop特性开发的,不兼容php4版本。所以在您使用zentaoPHP框架之前,请确认您的环境满足下面的要求:

1. web server最好是apache。因为它和php集成使用是稳定,功能也是齐全的一套组合。
2. PHP低版本是5.2版本。
3. 数据库目前只支持MySQL,版本4.x以上。


现在amp组合的安装比以前已经简单多了。windows下面的用户可以考虑使用xammp。linux下面的用户直接使用包管理进行安装就好了。比如debian下面的apt,红帽下面的rpm, yum。FreeBSD的用户可以直接使用ports安装,也是非常方便的。

评论列表
Ankyliu 2016-08-18 15:02:36
找到一个笔误:1. web server好是apache
应该是:1. web server最好是apache
王春生 2016-08-19 08:18:37
谢谢指正,已经修改。
apache 2016-04-01 14:47:51
apache的版本有限制没?
王春生 2016-04-05 08:08:51
没有限制。
php7 2015-12-28 12:00:14
你的php版本太高了,官方只支持f十年前的php5.3
王春生 2015-12-28 15:30:25
我们是最低要求5.2,php7可以运行,没有问题。
2017-03-29 13:13:07
好多人都用7了,不是号称不改代码直接升级吗?
王春生 2017-03-30 08:10:17
早就支持php7了。
Zentaouser 2015-04-24 13:43:01
在windows下进行安装时报500 Interval错误,查看apache错误日志,提示 ‘.htaccess: Invalid command 'php_value', perhaps misspelled or defined by a module not included in the server configuration’错误,请问如何解决(采用一键安装包安装的集成环境)
1/1
发表评论
评论通过审核后显示。